1992 Buick Century Has No Power on Acceleration

Problem with my 1992 Buick Century.
Work done to repair this problem = new starter, second hand power steering, new belt, new alternator, oil change, new battery.

question = My car started to loose power going up a hill and when i would step on the gas it would not rev up as soon as it should have. Now it doesn't want to start when i tried to start it, it's like it wanted to but wouldn't all the lights come on.

I know its not the battery and then when i kept trying it started to smoke but never did start then i heard a pop. so i stopped trying thought it might be the trany could you help me please so that i can take it to a mechanic or call a friend to fix it?

Answer: This does not sound like a transmission problem, since you say that the engine will not rev up. A transmission problem would cause the engine to rev way too high, but not accelerate. This sounds like a possible fuel pressure problem. Loosing engine power, and not starting is a sign a low or no fuel pressure. This can be caused by a plugged fuel filter, or bad fuel pump. You would need to have a gauge installed to check this.

If the check engine light is on, the computer would need to be scanned for trouble codes. A fuel pressure problem would not set a check engine light, but if there were another problem, like a sensor, it would turn that light on the dash.

Question: 1996 Buick Century.3.1L V6. Car reaches operating temp achieves closed loop runs awhile then starts going between closed and open then goes open and dies. Tested all sensors test out good.

Sounds Like you have a faulty oxygen sensor. Although the sensor may seem to be fluctuating normally, it would start to stay in a specific range for a long enough time that the ECM will see this as inactivity, and go into open loop. back and forth into closed and open loop will eventually cause the car to stall.

Please login to comment

Comments (1)
   ---Subscribe To Your Comment   

  • Guest - WPD

    Check the Catalytic Converter....just had same problem...took out the O2 sensor and ran up the same hill with more acceleration...replaced Converter...problem solved!